error recaptcha v1 prestashop 1.6

ERRROR: reCAPTCHA V1 obsoleto

Nos han comentado que están surgiendo problemas en algunas tiendas que usan el módulo recaptcha, ya que no se visualiza la imagen para poder descifrar la palabra/s antes de enviar el email.

A estas alturas todos sabéis que es reCAPTCHA de Google, pero por si acaso, es un detector que opera en servicios web y que diferencia entre humanos y bots. Google reCAPTCHA muestra diálogos para asegurarse de que, en efecto, el usuario sea una persona.

Este error es derivado del uso de una versión de reCAPTCHA que está apunto de quedarse obsoleta, la versión V1, y que necesitamos cambiar a la versión V2 (o a la versión NO VISIBLE) que nos proporciona Google para solucionarlo.

Podéis distinguir si tenéis la V1 o la V2 en la siguiente imagen;

Versión V1

error recaptcha v1 prestashop 1.6

Versión V2

error recaptcha v1 prestashop 1.6

 

Solución a Imagen reCAPTCHA no se visualiza en Prestashop 1.6:

Para solucionar este error tenemos que:

1.- Eliminar el módulo Captcha desde Módulos.

imagen recaptcha no se visualiza prestashop 1.6

2. Renombrar o eliminar (descarga y guarda antes) el archivo ContactController.php que está en;

override/controllers/front/ContactController.php

Después de realizar estas 2 acciones ya no debe aparecer el recaptcha V1, ahora tenemos que conseguir mostrar el recaptcha V2 para evitar problemas con bots. Este paso os lo explciaremos en el siguiente post.

Hosting

Sobre el Autor: Franky Martin (ADMIN)

Deja un comentario

Tu dirección de email no será publicada.

uno × 3 =